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1
Introduction

Welcome to the OW5000 Dialer User Guide. The OW5000 Dialer User 
Guide provides the information you need to work with the Dialer 
application. 

Chapter Topics • What is OW5000 Dialer?
• How This Guide is Organized
• Using This Guide
• Dialer Keys and Prompts

What is OW5000 Dialer?

Dialer is an OW5000 application that enables NEC Dterm users to access 
a corporate-wide directory on their telephone display. With OW5000 
Dialer, you can search for an employee in the entire corporate directory 
or within a specific division or department. You can also search for 
External Organizations created by using the OW5000 Administrator 
application.

Once Dialer locates the name or location that you are looking for, it 
displays the information on your NEC Dterm telephone. You can then 
place or transfer a call to the telephone number corresponding to that 
entry.

Database entries are stored in the same database used by other 
OW5000 applications such as the OW5000 Admin. Queries to the 
database are dynamic. Any changes made to directory items through 
the OW5000 Admin or other OW5000 applications will immediately be 
available in Dialer.

How This Guide is Organized

Chapter 1 
Introduction

This chapter outlines how to use the manual, including the actual 
manual organization, chapter layout, conventions, and function keys for 
the Dialer application. 

Chapter 2 
Using Dialerr

This chapter explains how to locate, view, and call a telephone number 
using the Dialer application.
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Using This Guide

This guide is designed to make the OW5000 Dialer application easy to 
understand and simple to use. There are examples of the information 
you will see displayed on the Dterm used to access the Dialer 
application, with step-by-step instructions for the procedures you need 
to perform.

Document Conventions

The conventions used in this document are shown in Table 1-1.

Table 1-1  Document Conventions 

When you see: It means: Example

Boldfaced 

• Field names

• Button names

• Drop-down list names

• Commands, keywords, or 
other user input

Enter the ID in the Name field.

Click Save.

Select the names from the 
Employees drop-down list.

Enter login admin at the 
command prompt. 

Capitalized 

• Menu names

• Window names

• Dialog box names

From the File menu, choose 
Save.

From the Directory window, 
select Edit > Modify. 

Click OK to save and close the 
Account Properties dialog box.

Menu > Submenu
(boldfaced font) • Menu paths Select Edit > Modify.

CTRL+S

(boldfaced font)

CTRL+Shift+S

• Shortcut keys Press CTRL+S to save your 
changes.

F1

(boldfaced font)
• Function keys Press F1 to access the online 

help. 

Click

Right-click

• Click the left mouse button

• Click the right mouse button

Click OK to save your changes. 

Right-click and select Delete 
from the shortcut menu.

Warning 
Used to warn against possible 
human injury or risk of death 
from an action or event.
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Procedures

Step-by-step instructions are numbered. Simply follow the numbered 
steps to perform the desired function.

Sometimes in step-by-step instructions, you will have more than one 
option to complete the task. The following shows options to the example 
step in a procedure: 

Step  1 Do one of the following to add a field to the Employee directory. 

—Select the desired field from the Employee field and click Add. 

—Double-click the desired field from the Employee field.

Step  2 To select all of the available fields, click Add all.

Caution
Used when equipment or data 
could be damaged by an action 
or event. 

Important Emphasizes a MUST read 
statement.

Note

Used to point out special details 
that you must know or actions 
that you must take relevant to 
your current actions.

Tip
Describes time-saving ideas and 
other useful information for 
completing procedures.

Reference Indicates a reference to another 
related document.

When you see: It means: Example
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Dialer Keys and Prompts

The Dterm components are shown in Figure 1-1.

Figure 1-1  Dterm Components

Keypad Conventions

When Dialer is activated by pressing the assigned OAI key on your 
Dterm phone, the prompts are displayed on your Dterm LCD screen. 
Use the keys shown in Figure 1-2 and described in Table 1-2 to scroll 
through and select the desired information.

Figure 1-2  Scroll List Function Keys

Display

Feature Keys

Keypad
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Table 1-2  Scroll List 

Key Function Description

1 Top Displays the first entry in scroll list

2 Scroll Up Displays the previous entry in scroll list

3 Prev Letter Displays the first entry with the previous letter

4 Scroll Left Displays additional entry information

5 Add Letters Adds more letters to the search string

6 Scroll Right Displays additional entry information

7 Bottom Displays the last entry

8 Scroll Down Displays the next entry

9 Next Letter Displays the first entry with the next letter

0 Search Again Returns to the “Name” prompt if your query did not find the 
desired name

* Backspace Clears the entry if pressed before pressing # to enter the data.

# Enter Selects displayed entry

Function Key descriptions
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2
Using Dialer

OW5000 Dialer can be configured to display search prompts after the 
installation by using the OW5000 Administrator. 

See the OW5000 Dialer Installation Guide for more information about 
the installation process.

Basic Operating Procedure

If the Global List option is checked on the Dialer > Server Settings page 
in the OW5000 Administrator, Dialer displays the [Name?] prompt. 
Enter the name using the keypad and press # when finished. 

For example, if the caller is looking for “Joe Smith” and the display name 
is shown in First, Last name order, enter 563. Dialer will look up all 
matching names in the database and display the first matching name 
found. The user can then scroll through the list to find “Joe Smith” using 
the navigation keys, as described in Directory Search Example. 

If the Global List option is not checked, Dialer will display prompts in the 
following order.

• Dialer checks the database for a list of companies. If one, or more 
than one, company is found, Dialer checks to determine if the calling 
extension has selected names during a previous session, then displays 
the last company searched. 

• If the extension has not accessed Dialer previously, the first company 
in the list displays, and the Global and External options display at 
the end of the list. Do the following:
— Select [Global] to search all local names for matches. 
— Select [External] to search all names in the external number 

database for matches.
— Select a company to search all names under that company.

• If a company has been selected by pressing the # key, Dialer will do 
the following:
— If more than one Division is found in the database, the [All 

Divisions] prompt displays. Use the navigation keys shown in the 
Directory Search Example to scroll through the list and select the 
desired Division. 
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• If there are no divisions in the db, or when the desired division is 
selected by the user, the Dialer will do the following.
— If more than one department was found, the [All Departments] 

prompt displays. Use the navigation keys shown in the Directory 
Search Example to scroll through the list and select the desired 
department. When the desired department is selected, the 
[Name?] prompt displays. Enter the name using the keypad and 
press # when finished.

— If one or no departments were found for that division, the 
[Name?] prompt displays.

• The search results are listed alphabetically on the LCD. Use any of the 
Dterm key functions to scroll through the list and display additional 
data. If your search returns too many names to scroll through, press 
5 to display your original search criteria. Then, use the keypad to add 
additional letters to narrow your search and press # to search again. 

• Dialer can be configured to display extension data in the name scroll 
list. If the Name/Extension option is checked on the Dialer > Server 
Settings page in the OW5000 Administrator, then extension numbers 
are displayed with internal directory entries. The name is truncated 
down to a minimum of 9 characters long so the entire extension will 
fit. This means the name and extension will display on the same line if 
the extension is at most 6 characters long. Otherwise, the name is 
written out up to 13 characters and >> is appended to indicate the 
full number is on the next line.

If no name matches your search criteria, the [No Such Name] 
prompt is displayed, and you can press 0 to return to the [Name] 
prompt and search for another name or exit and start a new session 
to select a new company, division, or department.

• When a name has been selected, Dialer attempts to make the call. If 
the calling terminal is off-hook and connected, Dialer will transfer the 
connected party to a new number. (See Transferring or Conferencing 
a Call for more information.) When transferring a call, Dialer exits and 
the display is then handled by the PBX. The PBX displays [XFR] on 
the Dterm’s LCD, followed by the number. If the call is not successful, 
Dialer will display the following:
• [Line Busy] if the called party is busy.
• [Invalid Number] if the number cannot be found.
• Otherwise, [Unable To Call] will be displayed.

• If one or no keys were pressed for the name search, Dialer will display 
[Need Two Letters], which is the minimum number of digits 
required to make a database search. If no matches are found, Dialer 
will display [No Such Name] and will allow the user to enter a new 
string of digits.

The names can be entered and selected as described only if the Global List option is 
selected after the installation, using the OW5000 Administrator. (See the OW5000 
Dialer Installation Guide for more information.)

NOTE
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Transferring or Conferencing a Call

You can use Dialer to transfer a call or to conference a third party into a 
conversation by using the following steps:

Step  1 While in a conversation, press the Dialer function key and follow the 
steps above to search for a name in the directory.

Step  2 Accept the displayed name by pressing the # key.

Step  3 Do one of the following to transfer or conference the call:

—To transfer the call, hang up. The phone of the selected individual 
rings, and the party that you were talking to hears a ring-back tone.

—To conference the third party, press the conference key (CNF) on your 
Dterm. All three parties are connected.

If the call is not successful, Dialer will display the following:

• [Line Busy] if the called party is busy.
• [Invalid Number] if the number cannot be found.

• Otherwise [Unable To Call] will be displayed.

If you are dialing a number on a different PBX and that number is busy, Dialer will 
quit without displaying an error message and will sound a busy tone.

Directory Search Example

The following example shows how to find an employee (Peter King) who 
works in the Payroll department of a multi-division company. 

To find Peter King who works for the XYZ Company’s Payroll Department 
in the Network Division, use the following steps:

When you activate Dialer, the first company in the company list displays, 
as illustrated in Step 1: 

Figure 2-1  Company Display

Step  1 Do one of the following:

—Press 8 to scroll through the companies configured in the database, 
until the desired company name displays. For this example, the XYZ 
Company (Figure 2-2).


NOTE

ABC Company
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OR

—Press 9 to advance through the first letters of the companies until 
reaching the “X’s”. 

Figure 2-2  Selecting a Company

Step  2 Press # to select the XYZ Company. The [All Divisions] prompt 
displays (Figure 2-3).

Figure 2-3  Division Selection (Global)

—Press 8 to scroll through the divisions configured in the database, until 
the Network Div displays.

OR

—Press 9 to advance through the first letters of the divisions until 
reaching the “N’s”. 

Figure 2-4  Division Selection (Specific)

Step  3 Press # to select the Network Division directory. The [All Departments] 
prompt displays (Figure 2-5). 

Figure 2-5  Department Selection (Global)

XYZ Company

All Divisions

Network Div
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Step  4 Do one of the following to select the Payroll department:

—Press 8 to scroll through the departments until the Payroll department 
displays (Figure 2-6).

—Press 9 to advance through the first letters of the departments until 
reaching the “P’s”. 

Figure 2-6  Department Selection (Specific)

Step  5 Since Peter King works in the Payroll department, press # while the 
Payroll prompt is displayed to select this option. The [Name] prompt 
appears (Figure 2-7). 

Figure 2-7  Name Prompt

Step  6 Press 546#. These numbers correspond to the first 3 letters of Peter 
King’s last name, and the # key indicates that you have completed your 
entry. The first name matching your search criteria displays (Figure 2-8). 

All Departments

Payroll

Name?
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Figure 2-8  Name Display

Step  7 Press 9 to display names starting with the next letter of the alphabet. The 
first name with a different first letter displays (Figure 2-9).

Figure 2-9  Scrolling Through Displayed Names

Step  8 Press 8 to show the next name in the list until the correct entry is 
displayed, as illustrated in Figure 2-10.

Figure 2-10  Selecting a Name

Step  9 Press 6 to scroll right. Press 4 to scroll left.

Press 6 repeatedly to scroll right to view the employee’s extension, division, and 
departmental information.

 

Step  10 Press # at any time to dial Peter King. The call is placed in speaker mode 
to the selected entry (Peter King).

Jines, Al

Kim, Andrea

King, Pete

NOTE



Using Dialer         2-7

OW5000 Dialer User Guide - Revision 7

Exiting OW5000 Dialer

To exit Dialer, press the function key on the Dterm associated with 
Dialer. If you do not press the function key within a configured amount 
of time, the application will exit automatically.
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For additional information or support on this 
NEC Infrontia Corporation product, contact your 

NEC Infrontia Corporation.
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